
Introduction
This tutorial explains how to build an application by using the Winproladder programming package to 
write a  ladder control program.
In this tutorial we will not tackle the advanced features of WinProladder, only the basic 
operations needed to build a simple application will involved. Hope this will lead the 
user into the world of WinProladder with less efforts.

Description of sample program
The application we will build in this tutorial is described as below:
Write a control program to generate a moving LED pattern by using the output indicators.
The time chart of output is shown below

At first Y0 will be 'on' for one second. After that Y1 will also 'on'. This will cycle to Y2 then Y3 ...
After Y7 is 'on', the next time all output will all be 'off' for 1 second. This 
procedures will repeat again as described above.

The corresponding control ladder program is  shown at below:
     

The content of element comment  will be built is shown below
    





General Features

�  Windows based application program. All the operations follow the convention of windows 
environment, easy for learning and operating. No matter beginner or Pro can operate with great 
efficient.

� Adopts project concept, which category the whole tasks of program to be developed with hierarchy 
tree. Through the visual effect the user can see through the whole project at first glance. No matter  
at program or maintenance stage all the jobs need to do can perform with intuitive.

� Provides the thoughtful and considerate entry method, incorporate both the keyboard and mouse 
for  entry device. No matter at field site or office environment can operate with ease and efficiency.

� Provides the connecting way of PLC and PC with varieties. Among the connections, there are hard 
wire connection, Modem connection and Internet connection. For every different connection 
WinProladder provide a session name to associate the setting of the communication parameters, 
such as port no., baud rate, IP address, phone number, etc.. With this feature can alleviate the user 
from the burden of the memorizing.



Program Editing

� Provides the on-line program editing capability. After modify the ladder program can send the RUN 
command immediately without to re-down load the program to PLC. With this feature can reduce 
the application development time dramatically comparing with other PLC without this feature. 

� Provides multiple ladder program windows, can show different fragmentation of ladder program at 
one time and perform the copy, paste and compare operation between these windows. 

� Provides the flexible ladder network editing capability. With the help of copy, paste and delete 
highly efficient operation can complete a complex program with few keystrokes.

� Provides the capability to divide the whole program into many program units. User can at will  
partition the whole development task into many independent program units according to the 
functionality or other classify methodology and perform the entry, editing, testing and documentation 
jobs independently. With this feature can greatly ease the maintenance of the whole application.

 � Provides the flexible program search capability, can search contact, register or function. Also can 
set a filter to narrow down the search object to ease the user from picking up the desire results 
among the whole bounces of search result. Best of all, just double click the interested message line 
can bring out the corresponding ladder program to the user.

� Provides a powerful syntax check tool. With this tool can parse the user's program and generate a 
parsing message in one message window. In this window all the warning or error messages regard 
the program will be listed line by line. User just double click the interested line then the ladder 
program will be shown on the window with the cursor stay on the question part.



Program Testing

� Provides multiple status monitoring pages. User can monitor and modify the status of discrete 
contacts and registers on the status page. Each discrete input and output (include the internal relay) 
can be disabled and forced on or off. Each register can be selected individually to show with 
different format such as hexadecimal, decimal and binary. Best of all, the layout of the status pages 
can be stored in the project and there is no need for user to re-define the page each time when 
he/she want to monitor the status.

� Provides multiple high lighted ladder program display window. The conducting condition of each 
contact element can be revealed by the color of the element drawing. The register value embedded 
with the function block also can be shown currently with ladder diagram. The discrete element can 
be easily disabled and forced on or off directly from the ladder diagram.



Program Documentation

Provides following report  function 

� Ladder diagram printout - Can select the scope and detail level of the ladder diagram for different 
kind of reporting requirements.
� Ladder element usage report printout ?Can list the statistics of all ladder elements used in the 
project and the cross reference list of all elements.



Working Desk Of The WinProladder

Before we proceed to build the first application program, we should first acquaint with the desk 
environment of WinProladder.
The screen shot shown on below is a typical working screen of  WinProladder.

The screen as you can see is consist of many operating areas, among these areas the most 
important are as follows

Main Menu
Most of the operations can be activated by using the mouse to left click the main menu and the pull 
down sub-menu.

Tool Bar 
Most of the major operations can be activated by using the mouse to left click the button on this area.

Component Pallet
The buttons in this area are used while perform the  ladder program entry or editing.

Status Bar
This area provides the information about the PLC connection mode and it's connecting status, current 
cursor position, ladder memory utilization, insert or overwrite mode.
 
Project Tree
This area outline  the whole project with hierarchy tree. All the jobs needed to work out can be 
activated by direct click the mouse button on the tree object. which lead an intuitive working 
environment.



   
Ladder Diagram
User can input or monitor the ladder program in this area. Winproladder allow the user open multiple 
ladder windows in this area at same time. The ladder windows can be tile horizontal or vertical or 
cascaded. Each window can contain more than one program unit, while operating can click the tab on 
the window to bring out the desire program unit.  



Create a new project

In this topic we will create a new project with the project name - tutorial.pdw

Step 1.
[Mouse] left click the main menu
File -> New Project
or 
[Keyboard] 
Ctrl + N

Then 'New Project'  dialog will be brought out.

Step 2.
Input the project name - ' tutorial project ' in the 'Project Name' filed and pickup one model in the 
'Model Name'  combo-list and then use the mouse left click the OK button or press the Enter key.



Ladder program entry

In this topic we will input the example ladder diagram step by steps.

Step 1. At first we will input the network N0 which is shown below

a. Input the timer contact

[Mouse]

Move the mouse pointer to the component pallet and click the  button then the pointer will change 
from the pure arrow shape into the a arrow shape with a A contact beneath with it.
At this time the cursor act like a stamp, if left click the mouse button will stamp a A contact on the 
click position.
Now move the cursor to the top most left position of ladder window and click then a dialog will pop out

     

Now enter the T0 with keyboard and  press Enter .
 
or
[Keyboard]
First move the cursor to the  top most left position of ladder window and  follow the key sequence BT0
 Enter  or T0B Enter or T0 Enter ( if previous key-in element is B contact) to enter the B timer contact. 
The key sequence BT0, B stands for B contact and T0 is the timer reference number. While key in,  a 
dialog will be popped up as mouse input method but can ignore it and continue to key in the other 
keys.

b. Enter timer function

[Mouse]

Move the mouse pointer to the component pallet and click the  button then the pointer will change 
from the pure arrow shape into the a arrow shape with a T letter beneath it.
Now move the cursor to the position right next to T0 contact and click then a dialog will pop out

    

Now  enter the 0 at T: field then enter 100  at PV field and click the OK button  or press  Enter .
 
or
[Keyboard]
Press the  Shift+T key to bring out a dialog which is the same as the mouse input,  and then enter the 
0 at T: field then use Down key to move cursor to PV: field then enter 100  and  then press  Enter . 

Step 2. Enter the network N1 which is shown below



a. Enter the  T0 A contact

[Mouse]

Move the mouse pointer to the component pallet and click the  button then move the pointer to 
the N1 network first row position and click then key-in T0 Enter. 

[Keyboard]
Move the cursor to the N1 network first row position and then press AT0 Enter.

b. Enter the SHFT function

[Mouse]

Move the mouse pointer to the component pallet and click the  button then move the pointer to 
the position right next to the T0 contact and click then a dialog will pop out

Now enter SHFL Enter or 51 Enter or click the 'Shift/Rotate' item in the class field and then pick 
'SHFL' in the Name field then SHFL will shown in the Function Name field and then press Enter key. 
After above operation then will pop up a dialog as follow

Use mouse to click the check box of Pulse to check it ( to make this function pulse activated) then
complete the input of D: and N: field. If you do not know or forgot the meaning of D: or N: filed can 
move the pointer above the filed name you questioned then there will appear  a hint. Also if you forgot 
the valid input range or data type of specific field you can move the pointer to that input field and there 
also will appear a hint about the valid data type and range . 



[Keyboard]
Very similar to mouse input. The only difference is that keyboard input method use F key to bring out 
the function lookup dialog.

Step 3. Enter the network N2 which is shown below

a. Enter the contacts of network of N2 

[Mouse]
Move the pointer to N2 network and follow the method described at step 2 to  input the M1924 
contact and then move the pointer to the row beneth M1924 then input M6 contact.

Move the pointer to component pallte and click the  button then move the pointer to the position 
next to M1924(column 2) and click the mouse left button then M1924 and M6 will vertically join 
togather with a vertical short.

or
[Keyboard]
Move the cursor to N2 network and enter the M1924 contact as described in step 2 then press the 
Enter key then the cursor will move to the position beneth M1924. 
Input M6 contact and use Up key move the cursor to the position next to M1924 then press V key to 
input a vertical short.

b. Enter MOV function

Please refer to the input method described at step 2 to enter this function.

Step 4. Enter the network by copy operation

a. Enter a simple network
In this step we will use copy operation to enter the reset of the ladder program. We will leave the  
network shown below not to enter deliberately until next topic.

The network we are going to enter is shown as follow

There is nothing special to enter the first network shown above as compare to previous. So follow the 
same procedures described above to complete this. 



The network leaded by M1 contact thru. the network leaded by M7 contact are very similar to the first 
network, so we can use copy operation to complete this part of entry. Here is the procedures,
Move the mouse pointer to the first network shown above and hold down the left button of mouse and 
drag down or right
or use keyboard
Hold down the Shift key and press Up or Down key 
until the first network is selected then click the menu items as follows
Edit -> Copy
or use keyboard
Ctrl + C
Then move the mouse pointer to the next network and click the menu items as follows
Edit -> Paste
or use keyboard
Ctrl + V
then there will be a new network identical with the first nextwork appears.
Follow the same procedures described above to make the template of next two networks. After that 
make these two networks copied again to build the next 4 networks. So with 3 times copy and paste 
operation we can complete the all 8 networks. The last step is to modify the reference number of the 
networks built by previous operations. 

Step 5. Save the project

[Mouse]
File -> Save then key-in tutoria Enter

[Keyboard]
Ctrl + S then key-in tutoria Enter
 
 



Ladder Program Editing

Insert a network

In this topic we will finish the entry of network N3 which did not enter at previous topic. The network 
N3 is shown at below

Method 1.

Move the mouse pointer to the network N3( latter will become N4) and click the  then network N3 
will be selected.
Click the right button of mouse then will appear a popup menu as shown below

click the 'Insert before this network' item then an empty N3 network appears.
Repeat this procedure once to get another empty network.
Follow the procedure described in the previous topic to enter the whole network.

Method 2.

Press Ins key to enter the insert edting mode. The cursor now will change from the solid box to hollow 
box.  
Move the pointer to the first element of Network N3 and click then press Enter key then an empty 
network will appear.
Enter the T0 conatct and counter function then move the pointer to the position beneth T0 to enter the 
M0 contact and vertical short to finish this network entry.

Edit the reference number of element

a. Contact
Move the cursor to the element required for editing and direct input the new reference number( or 
contact type) and press Enter or press Space key or double click the left mouse button to bring out 
the editing dialog.

b. Function block
Move the cursor to the function block required for editing and press Space key or double click the left 
mouse button to bring out the editing dialog.

Ladder Syntax Check



a. Check ladder

Click the menu item as follows
Tool -> Syntax Check
or press shortcut key
F8 to check the ladder.

a. Set the option of syntax check

Click the menu item as follows
Project -> Option
or press shortcut key
Ctrl + F8 to change the setting of synatx check options.



Ladder Program Testing
In this topic we will changed the working mode from off-line to on-line. Because all the modifications 
to project will only save in the disk while in off-line operating mode, so before begin to test the 
program we must first save the project data to PLC. The project data can be transferred to PLC 
include ladder program, element comment, table data and configurations while network comment and 
program unit comment can only exist in the project file.

Save project data to PLC

Click the menu items as follows
File -> Save AS -> To PLC   then  a dialog will pop up as follow

There are three pre-defined connection sessions can be found in the 'Connection Name' combo list 
which are RS232, UDP, TCP. In this tutorial we assume to connect the PLC with serial line so we can 
pick RS232 or create a new cession with click the New button which will bring out an wizard to direct 
you to create a new cession. If you don't want to create a new cession but the pre-defined session is 
not exactly what you want then you can click the Edit button to change it.

After click the OK button the WinProladder will try to connect with PLC, if the connection success 
then a mesasge box will shown as below



Click OK button to return to the ladder window.

PLC start and run control

[Mouse]
Click the menu as follows
PLC -> Run PLC -> OK to start the PLC.
 or while PLC is running
PLC -> Stop PLC -> OK to stop the PLC.

[Keyboard]
Press the keys
Ctrl + F9 Enter to  Stop the PLC.
F9 Enter to start the PLC.

Ladder Monitoring

While operate at on-line mode and PLC is running, the ladder diagram will displayed with high-light 
the conducting(short) contact will drawn with a red box as shown below

As you  can see T0 B contact is short ( because the status of T0  is off).
All the discrete elements can be disabled then force on or off right at ladder window. For eample if 
want to force the M0 then just move the cursor over the M0 conatct or coil then click the right mouse 
button to pop up a menu as shown below

Click the desired item to control the element state. All the disabled element in the ladder diagram is 



different than normal element in appearance as shown below in order to differentiate them with ease.

The diagram shown above, M0 and Y0 are disabled.

View live register data in ladder diagram
The ladder diagram default is not to show the register value, if want to view the live register data can 
click the menu item as follows
View -> Register content 
or press the shortcut key
F11 to activate it.

A sample ladder diagram with live register data display is shown below

Status Monitoring
Winproladder provides a multi status-page feature allow user to monitor a bunch of contact status or 
register value at one time.

Create a new status page

Click the mouse button at project tree window on the icon   and right click to pop up a 
menu then click  'New Staus page' 
or Click the menu items as follows
Project -> Status Page -> New Status Page

A sample status page is shown at below



The discrete element can be disabled/enabled, force on or off  by just click the mouse right button to 
bring out the menu shown below 

The register can be selected to show in binary, decimal or hexadecimal format by click the mouse 
right button to bring out the menu as shown below

The ' ref No.'  field of  staus page default is to show reference number, for readability this field can 
selected to show with comment. This can be set by click the ' View element comment' .

Define the items for monitoring in the status page

The items in the status page can be defined with following syntax
item,item ... 
where item can be a signle item or a range of item. A range of  item can be expressed by two single 



item separated by '-' or '~' symbol. For example
X0,X2-X5,Y0-Y5,R0-R5 can define 17 items with one command.

 

 



Project Documentation

Element Comment Editing

Method 1. Input comments while enter the element

While input or editing the element a dialog will shown as follow

Click the icon  adjacent to the item for comment will pop up another dialog as shown below

Enter the comment and description of the specified reference number in this dialog then press Enter.

Method 2. Input comments by element comment editor

Click the menu item as follows

Project -> Comment -> Element Comment to bring out the element comment editor as shown below



 

With this editor can edit more than one element comments at one time.

Different type of reference number can be accessed by click the button( Ex.  ) belong to that 
type.

Network Comment Editing

Method 1. Enter the network comment while editing the ladder program.

Move the cursor to the network  that intended for comment and click the right mouse button then a 
menu popped up. Click the 'Network Comment' menu item to edit the network comment.

Method 2. Enter the network comment with network comment editor.

Click the menu items as follows

Project -> Comment -> Network Comment to bring out the network comment editor as shown below

Program Unit Comment Editing

Please refer to the description of the section 'network comment editing'  to edit the program unit 
comment.

View The Document With Ladder Diagram

Whenever input the network or program unit comment, the document will be shown automatically 
while the element comment is not. You must set the element comment visible by manual.
To set the element comment visible can click the menu items as follows
View -> Element Document to toggle the setting.
Similarly, the network and program unit comment can set to visible or invisible by click the menu 
items as follows
View -> Network Document
View -> Program Document 
If the document is visible then there will be a check sign before that menu item.   



Report Generation

Element Statistics

Click the menu items as follows
Tool -> Element Statistics to bring out the Statistics window as shown below

Printer Out The Ladder Diagram

Click the menu items as follows
File -> Print ...  to bring out a dialog as shown below

The program units in the 'Program Units List' can be multi-selected for print out. To select the 



program unit can hold down the Shift key while click the mouse button to mark a range of program 
unit or hold down the Ctrl  key while click the mouse button to multi-select a program unit.
Check or uncheck the check box to include or exclude the respective comment in print out.
The text enter into the header field will appear at each report page.



Ladder Element Entry 
   

Ladder Element
------------------------

Shortcut Key Description
----------------------------------------------------------------------------

A contact  A                       Input A contact and reference number
 Shift + A            Input A contact only

B contact  B                          Input B contact and reference number
 Shift + B                 Input B contact only

TU (up one shot) 
contact

 U                          Input TU contact and reference number
 Shift + U            Input TU contact only

TD (down one shot) 
conatct

 D                       Input TD contact and reference number
 Shift + D             Input TU contact only 

Coil  O                       Input coil and reference number 
 Shift + O             Input coil only

Inverse coil  Q                        Input inverse coil and reference number
 Shift + Q             Input inverse coil only

Note: While input, can first key-in the reference number (start with X,Y,M,S,T,C) then 
key-in element  (A,B,U,D,O,Q) , reverse the key-in order also can be accepted.

Power flow
Power flow inverse

     I
     N

Power flow up one shot P

Power flow down one 
shot

N

Horizontal short H

Continuous horizontal 
short

Shift + H

Vertical short V

Function block F

SET function Shift + S

RST function Shift + R

Timer function Shift + T

Counter function Shift + C



Ladder Element Editing 

Function
----------------------------

Shortcut Key Description
---------------------------------------------------------------------------

Modify reference number
 

Direct input the new reference number
or press the SPACE key to bring out the dialoge window for 
editing

Modify the reference number 
within  the function block

Press the SPACE key and bring out the dialoge window for editing

Delete the conatct or function 
block

Press the Delete key or  Backspace key



Network Editing  
  

Function
----------------------------

Shortcut Key Description
---------------------------------------------------------------------------

Insert a new network Shift + Insert (insert above)
Ctrl + Insert (insert below)

Delete a single network Ctrl + Delete

Select all the networks in the
program unit

Ctrl + A

Copy networks Ctrl + C

Paste networks Ctrl + V

Delete networks Delete

Cut networks Ctrl + X

Note: Before perform the network copy,paste,delete,cut operation should use the mouse to select the 
networks desired to operate.



Cursor Movement 

Function
----------------------------

Shortcut Key Description
---------------------------------------------------------------------------

Up,Down,Left,Right Move Up,Down,Left,Right key

To first row Home

To last row End

To next row Shift + Enter  

To next network Enter

To fisrt network of current
program unit

Ctrl + Home

To last network of current
program unit

Ctrl + End

To specific network Ctrl + G



Project Management 

              Function
----------------------------

Shortcut Key Description
---------------------------------------------------------------------------

Create a new project Ctrl + N

Open a project Ctrl + O

Connect to PLC Ctrl + L

Save the project  Ctrl + S 



PLC Control 

Function
----------------------------

Shortcut Key Description
---------------------------------------------------------------------------

Stop the PLC Ctrl + F9

Start the PLC F9



Ladder element search 

Function
----------------------------

Shortcut Key Description
---------------------------------------------------------------------------

Find element Ctrl +F

Find next element F3



Misc. Operations

Function
----------------------------

Shortcut Key Description
---------------------------------------------------------------------------

Setup project options Ctrl + F8

Syntax check F8

Generate report Ctrl + P

Display ladder with live
register data 

F11
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